ROS分时段限速2

作者:zqcheng    发布于9年前 (2010-01-12)    阅读:  162  次

:for szwm from 1 to 253 do={/queue simple add name=(A . $szwm) dst-address=(192.168.1. . $szwm) max-limit=1600000/800000

interface=lan time=0h0m0s-11h59m59s,mon,tue,wed,thu,fri disabled=no}

星期一到星期五
00:00:00到11:59:59 192.168.1.1-253 下载为200KB,上传100KB

:for szwm from 1 to 253 do={/queue simple add name=(B . $szwm) dst-address=(192.168.1. . $szwm) max-limit=800000/400000

interface=lan time=12h0m0s-23h59m59s,sun,sat disabled=no}

星期一到星期五12:00:00-23:59:59 192.168.1.1-253 下载100KB,上传50KB

:for szwm from 1 to 253 do={/queue simple add name=(C . $szwm) dst-address=(192.168.1. . $szwm) max-limit=560000/320000

interface=lan time=0h0m0s-23h59m59s,sun,sat disabled=no}

星期六00:00到星期天23:59:59 192.168.1.1-253 下载70KB 上传40KB

上面就是完整脚本了

A代表0:00到11:59 下载为200KB,上传100KB

B代表12:00-23:59 下载100KB,上传50KB

C代表星期六00:00到星期天23:59:59 下载70KB 上传40KB

我网吧30M电信光纤,230台客户机。10台服务器, 服务器:全年365天固定限速 电影2M。游戏更新2M,收费机1M。

不觉得卡,惟独客人星期六星期天下载有点慢,那是没办法的,

三个月前用这脚本,就发现晚上客人多了点,主要就是附近网吧的,晚上我这网速快,下载也快,招揽了一些客人,

不过晚上网吧上网的人也就70 80人。

到了下午4点后,高峰期来了,网吧属工业区,。主要就是做厂里的生意,

晚上6点左右全场爆满到晚上10点左右,

客人反映良好,

完整脚本为,

:for szwm from 1 to 253 do={/queue simple add name=(A . $szwm) dst-address=(192.168.1. . $szwm) max-limit=1600000/800000 interface=lan time=0h0m0s-11h59m59s,mon,tue,wed,thu,fri disabled=no}

:for szwm from 1 to 253 do={/queue simple add name=(B . $szwm) dst-address=(192.168.1. . $szwm) max-

limit=800000/400000 interface=lan time=12h0m0s-23h59m59s,sun,sat disabled=no}

:for szwm from 1 to 253 do={/queue simple add name=(C . $szwm) dst-address=(192.168.1. . $szwm) max-limit=640000/400000 interface=lan time=0h0m0s-23h59m59s,sun,sat disabled=no}