ROS小包优先+带宽均分+简单队列限制

Wordpress zqcheng 148℃

一直以来,都看论坛上的达人说ROS做软路由器效果是多么的强大,于是偶也搞一个试试看。找了一

个2.9.27的完全破解版,用了2块D-LINK530的网卡,装完一用还真行。比我那1000的锐捷强多了,网

吧120台机器,座满的时候那个锐捷的路由器登陆界面都打不开。用上以后问题就来了,我们30M的光

纤,如果不限速,那些下载狂人把带宽全部给占用了,打游戏的顾客很有意见。于是我就做了个限速

,每个机器下载最大2M.平均1M。但是群众还是不满意,都所卡。我又找资料,发现原来还有个叫智

能动态限速的东西,好偶照做。做好以后,平时喊卡的人没有了,人多的时候一样都喊卡。

偶傻眼了,难道只能不限速。还好天无绝人之路,还有个“小包优先”的高级货,于是照做。结果用

简单队列限速后,“小包优先”也是白搭,难道天要忘我。终于经过N次测试以后,我明白了。网吧

用简单队列做限速完全是扯蛋。网吧限速最好的办法应该是带宽均分,然后在用简单队列来限制上传

。在利用小包优先来处理游戏卡的问题。经过2个网吧,一个月的测试,完全摆脱了到处喊卡的噩梦

,现在把经验发来大家分享一下。

ROS不要用简单队列来限速,什么智能动态限速也不要用。只需要用小包优先+带宽均分+简单队列限

制上传速度。

小包优先的脚本如下:

ip firewall mangle
add chain=forward p2p=all-p2p action=mark-connection new-connection-mark=p2p_conn passthrough=yes comment=”” disabled=no
add chain=forward connection-mark=p2p_conn action=mark-packet new-packet-mark=p2p passthrough=yes comment=”” disabled=no
add chain=forward connection-mark=!p2p_conn action=mark-packet new-packet-mark=general passthrough=yes comment=”” disabled=no
add chain=forward packet-size=32-512 action=mark-packet new-packet-mark=small passthrough=yes comment=”” disabled=no
add chain=forward packet-size=512-1200 action=mark-packet new-packet-mark=big passthrough=yes comment=”” disabled=no

/ queue tree
add name=”p2p1″ parent=cnc packet-mark=p2p limit-at=2000000 queue=default   priority=8 max-limit=6000000 burst-limit=0 burst-threshold=0 burst-time=0s   disabled=no
add name=”p2p2″ parent=lan packet-mark=p2p limit-at=2000000 queue=default   priority=8 max-limit=6000000 burst-limit=0 burst-threshold=0 burst-time=0s   disabled=no
add name=”ClassA” parent=lan packet-mark=”” limit-at=0 queue=default   priority=8 max-limit=100000000 burst-limit=0 burst-threshold=0   burst-time=0s disabled=no
add name=”ClassB” parent=ClassA packet-mark=”” limit-at=0 queue=default   priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s   disabled=no
add name=”Leaf1″ parent=ClassA packet-mark=general limit-at=0 queue=default   priority=7 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s   disabled=no
add name=”Leaf2″ parent=ClassB packet-mark=small limit-at=0 queue=default   priority=5 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s   disabled=no
add name=”Leaf3″ parent=ClassB packet-mark=big limit-at=0 queue=default   priority=6 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s   disabled=no
然后是带宽均分:

/ip firewall mangle add chain=forward src-address=192.168.0.0/24
action=mark-connection new-connection-mark=users-con
/ip firewall mangle add connection-mark=users-con action=mark-packet
new-packet-mark=users chain=forward

/queue type add name=pcq-download kind=pcq pcq-classifier=dst-address
/queue type add name=pcq-upload kind=pcq pcq-classifier=src-address

/queue tree add name=Download parent=lan max-limit=30M
/queue tree add parent=Download queue=pcq-download packet-mark=users
/queue tree add name=Upload parent=wan max-limit=28M

/queue tree add parent=Upload queue=pcq-upload packet-mark=users

请根据直接实际修改IP地址段,下载最大速度,上传最大速度,lan为我连接内网的网卡,wan是我连

接外网的网卡
限制上传速度的脚本:

:for aaa from 2 to 180 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. .

$aaa) limit-at=10000000/3000000 max-limit=30000000/3000000}

如果是3.2版本的,这个脚本自己要修改下,

就用这3个部分,别的不需要的,绝对比什么智能动态限速好的多。

转载请注明:零度工作室 » ROS小包优先+带宽均分+简单队列限制

喜欢 (0)or分享 (0)
皖ICP备10205284号